Issue on Production
Incident Report for Kili
Postmortem

Issue on Production

Opened: 09 AUG 2023 (9:24 UTC)   

Resolved 09 AUG 2023 (09:46 UTC)

Incident duration: 20 mn 

End-User Impact

Users can not reach their projects

The incident was already resolved when SAP opened a ticket. A clear cache resolved this persistent issue. 

What caused the incident?

Issue with idempotence in the front-end build process, leading to different file IDs when the front end is built multiple times.

Corrective elements : 

We Identified and rectified the root cause of non-idempotence in the front-end build process. We prevented rebuilding the front if it has already been built

Posted Nov 24, 2023 - 08:20 UTC

Resolved
This incident has been resolved. If you encounter any issues connecting to Kili, we kindly advise you to clear your cache.
We are sorry for the inconvenience this Production incident may had on your teams.

Thank you for your understanding,
Kili Support team
Posted Aug 09, 2023 - 09:46 UTC
Investigating
We are currently investigating this issue.
Posted Aug 09, 2023 - 09:24 UTC
This incident affected: Europe (Kili API).